<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":9,"applicationTime":274,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-83218492-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>TerrapinSportsReport.com  -  Spring Practice No. 14: News, notes and observations</title>
<meta content='TerrapinSportsReport.com  -  Spring Practice No. 14: News, notes and observations' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="J71fWYoqmuTk/t+l+n0rZTdMMakGHV9m4f57w8fuuBP3usHwzjK6/Oezy/O9fgeqB7nzy9NG6P5FysrfMDbd5A==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/tydks03k15540otbh7uy' property='og:image'>
<meta content='News, notes and observations from spring practice No. 14. ' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-13 09:41:24 -0500' property='article:published_time'>
<meta content='2018-04-13 09:41:25 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "maryland.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='maryland contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .maryland #programming > h1 {
      background-color: #cc0000 !important; } }
  .maryland > header .notification-link .count-container {
    background-color: #cc0000 !important; }
  .maryland > header .wrapper-container {
    background-color: #cc0000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .maryland > header .wrapper-container {
        border-bottom: 5px solid #ffcd23 !important; } }
  .maryland > header .invalid-email-banner {
    background-color: #cc0000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .maryland > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .maryland > header .invalid-email-banner a:hover {
      color: #ffcd23; }
  @media screen and (max-width: 767px) {
    .maryland > header .mobile-header {
      background-color: #ffcd23 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .maryland > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .maryland > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .maryland > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .maryland > header .nav-row > ul,
    .maryland > header .third-nav {
      background-color: white !important; }
    .maryland > header .dropdown-toggle > i.fa {
      color: #cc0000 !important; } }
  .maryland > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #cc0000; }
  
  .site-primary-font-color {
    color: #cc0000; }
  
  .site-primary-background-color {
    background-color: #cc0000; }
  
  .site-secondary-font-color {
    color: #ffcd23; }
  
  .site-secondary-background-color {
    background-color: #ffcd23; }
  
  :root {
    --outbrain-primary-color: #cc0000;
    --outbrain-secondary-color: #ffcd23; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-black'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Maryland" class="school-header" href="//maryland.rivals.com"><img src="https://res-5.cloudinary.com/rivals/image/upload/iw48dcemxmfqzval2wnz" alt="Iw48dcemxmfqzval2wnz" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//maryland.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;maryland&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//maryland.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;maryland&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733111,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Spring Practice No. 14: News, notes and observations"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='TerrapinNation' name='twitter:site'>
<meta content='Spring Practice No. 14: News, notes and observations' name='twitter:title'>
<meta content='News, notes and observations from spring practice No. 14. ' name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/tydks03k15540otbh7uy' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1913465,"title":"WATCH: Durkin previews upcoming Spring Game","slug":"watch-durkin-previews-upcoming-spring-game","kind":"free","site_id":72,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-12T15:39:23.758-05:00","summary":"Watch DJ Durkin address the media one last time ahead of the Terps&#x0027; annual spring game. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/watch-durkin-previews-upcoming-spring-game","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1913031,"title":"Terps add top scorer Serrel Smith\r\n","slug":"terps-adds-top-scorer-serrel-smith","kind":"free","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-11T14:05:48.946-05:00","summary":"The Terps nabbed the commitment of top available scoring guard Serrel Smith. ","deleted":false,"author_name":"Corey Evans","author_title":"Rivals.com","permalink":"https://maryland.rivals.com/news/maryland-adds-top-scorer-serrel-smith","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1912453,"title":"Maryland &#x0027;toward the top&#x0027; for three-star OL Jakai Moore following visit","slug":"maryland-toward-the-top-for-three-star-ol-jakai-moore-following-visit","kind":"premium","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-10T08:12:25.545-05:00","summary":"Patriot (Va.) three-star OL Jakai Moore breaks down his recent visit to Maryland and where the Terps stand.","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/maryland-toward-the-top-for-three-star-ol-jakai-moore-following-visit","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1911556,"title":"Bruno Fernando to declare for NBA Draft, will not hire an agent","slug":"bruno-fernando-to-declare-for-nba-draft-will-not-hire-an-agent","kind":"free","site_id":72,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-06T16:31:20.973-05:00","summary":"Maryland freshman center Bruno Fernando will declare for the NBA Draft but not hire an agent. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/bruno-fernando-to-declare-for-nba-draft-will-not-hire-an-agent","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1911447,"title":"Jalen &#x0027;Stix&#x0027; Smith McDonald&#x0027;s All-American highlights","slug":"jalen-stix-smith-mcdonald-s-all-american-highlights","kind":"free","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-06T09:08:21.877-05:00","summary":"Check out exclusive McDonald&#x0027;s game and practice highlights only from Rivals.com. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/mcdonalds-all-american-game-jalen-sticks-smith-highlights","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1911439,"title":"Others now seeing what Terps knew all along about D.J. Moore","slug":"others-now-seeing-what-terps-knew-all-along-about-d-j-moore","kind":"free","site_id":72,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-06T08:22:40.796-05:00","summary":"Coaches and teammates have known all along about DJ Moore what NFL personnel have just recently begun to learn. ","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/others-now-seeing-what-terps-knew-all-along-about-d-j-moore","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1910920,"title":"Spring Practice No. 10: News, notes and observations","slug":"spring-practice-no-10-news-notes-and-observations","kind":"premium","site_id":72,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-04T16:03:02.957-05:00","summary":"News, notes and observations from the Terps&#x0027; 10th spring practice. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/spring-practice-no-10-news-notes-and-observations","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1910607,"title":"South Carolina three-star TE Luke Deal talks Maryland visit, upcoming plans","slug":"south-carolina-three-star-te-luke-deal-talks-maryland-visit-upcoming-plans","kind":"premium","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-04T08:56:25.548-05:00","summary":"Three-star TE Luke Deal breaks down his recent visit to Maryland and where things stand in his recruitment. ","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/south-carolina-three-star-te-luke-deal-talks-maryland-visit-upcoming-plans","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1910480,"title":"Kameron Blount breaks down commitment to Maryland","slug":"kameron-blount-breaks-down-commitment-to-maryland","kind":"premium","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-03T20:00:36.933-05:00","summary":"St. Charles (Md.) three-star LB Kameron Blount became the second Maryland commit for 2019. ","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/kameron-blount-breaks-down-commitment-to-maryland","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1910406,"title":"WATCH: Durkin talks standouts, injuries and more at spring practice","slug":"watch-durkin-talks-standouts-injuries-and-more-at-spring-practice","kind":"free","site_id":72,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-03T15:54:38.636-05:00","summary":"Watch DJ Durkin address the media before the Terps&#x0027; third open spring practice. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/watch-durkin-talks-standouts-injuries-and-more-at-spring-practice","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909873,"title":"Ohio three-star DT talks Terps offer, upcoming visit plans","slug":"ohio-three-star-dt-talks-terps-offer-upcoming-visit-plans","kind":"premium","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-02T08:30:55.238-05:00","summary":"Springfield (Ohio) three-star DT Isaiah Gibson discusses his latest offer from Maryland. ","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/ohio-three-star-dt-talks-terps-offer-upcoming-visit-plans","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909724,"title":"Local three-star LB Kameron Blount commits to Maryland","slug":"local-three-star-lb-kameron-blount-commits-to-maryland","kind":"free","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-01T14:42:19.169-05:00","summary":"The Terps picked up their second commitment in the Class of 2019 in Waldorf (Md.) St. Charles LB Kam Blount. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/local-three-star-lb-kameron-blount-commits-to-maryland","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909626,"title":"Friedman&#x0027;s Takeaways: Baltimore Rivals adizero Combine\r\n","slug":"friedman-s-takeaways-baltimore-rivals-adizero-combine-1","kind":"free","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-31T19:44:29.023-05:00","summary":"The Rivals Camp Series presented by adidas made a quick stop in Maryland for the Rivals adizero Combine on Saturday.","deleted":false,"author_name":"Adam  Friedman","author_title":"Recruiting Analyst","permalink":"https://maryland.rivals.com/news/friedman-s-takeaways-baltimore-rivals-adizero-combine","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909517,"title":"Lefty Driesell elected to Naismith Hall of Fame","slug":"lefty-driesell-elected-to-naismith-hall-of-fame","kind":"free","site_id":72,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-31T12:22:28.462-05:00","summary":"Lefty Driesell has been officially named a member of the 2018 Naismith Memorial Basketball Hall of Fame class. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/lefty-driesell-elected-to-naismith-hall-of-fame","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909503,"title":"Five-star Jeremy Roach growing into his own and gathering interest","slug":"five-star-jeremy-roach-growing-into-his-own-and-gathering-interest","kind":"free","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-31T11:33:21.663-05:00","summary":"The five-star sophomore is developing an impressive resume - and the Terps are taking notice. ","deleted":false,"author_name":"Corey Evans","author_title":"Rivals.com","permalink":"https://maryland.rivals.com/news/maryland-s-jeremy-roach-growing-into-his-own-and-gathering-interest","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909377,"title":"Three-star UNC commit &#x0027;high on Maryland&#x0027; following latest visit","slug":"three-star-unc-commit-high-on-maryland-after-latest-visit","kind":"premium","site_id":72,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-30T13:34:20.082-05:00","summary":"Maryland recently hosted UNC commit and IMG Academy three-star CB Jayden Curry. He gives the latest.","deleted":false,"author_name":"Pat Donohue","author_title":"Staff Writer","permalink":"https://maryland.rivals.com/news/three-star-unc-commit-high-on-maryland-after-latest-visit","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909275,"title":"McDonald&#x0027;s AA Game: Ranking the week&#x0027;s top performers","slug":"mcdonald-s-aa-game-ranking-the-week-s-top-performers","kind":"free","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-30T09:00:05.932-05:00","summary":"See how future Terp Jalen Smith stacked up against his peers at this year&#x0027;s McDonald&#x0027;s All-American Game. ","deleted":false,"author_name":"Eric Bossi","author_title":"Rivals.com","permalink":"https://maryland.rivals.com/news/mcdonald-s-aa-game-ranking-the-week","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909031,"title":"D.J. Moore headlines Terps Pro Day","slug":"d-j-moore-headlines-terps-pro-day","kind":"free","site_id":72,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T12:47:15.467-05:00","summary":"News, notes and observations from the latest Terps Pro Day. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/d-j-moore-headlines-terps-pro-day","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908902,"title":"Four programs standing out for four-star Anthony Harris","slug":"four-programs-standing-out-for-four-star-anthony-harris-2","kind":"free","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-29T09:25:32.063-05:00","summary":"Maryland is one of four programs standing out to local four-star guard Anthony Harris. ","deleted":false,"author_name":"Corey Evans","author_title":"Rivals.com","permalink":"https://maryland.rivals.com/news/four-programs-standing-out-for-four-star-anthony-harris","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908781,"title":"Maryland guard Dion Wiley to transfer","slug":"maryland-guard-dion-wiley-to-transfer","kind":"free","site_id":72,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-28T19:04:16.807-05:00","summary":"Maryland redshirt junior guard Dion Wiley will graduate this spring and pursue transfer opportunities elsewhere.","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/maryland-guard-dion-wiley-to-transfer","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908768,"title":"Justin Jackson to declare for NBA Draft","slug":"justin-jackson-to-declare-for-nba-draft","kind":"free","site_id":72,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-28T18:25:56.383-05:00","summary":"Maryland sophomore forward Justin Jackson will declare for the NBA Draft. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/justin-jackson-to-declare-for-nba-draft","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908519,"title":"2020 four-star wing Myles Stute explodes onto scene at Metro Challenge","slug":"2020-four-star-wing-myles-stute-explodes-onto-scene-at-metro-challenge","kind":"premium","site_id":72,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-28T07:04:15.591-05:00","summary":"Gonzaga (D.C.) 2020 four-star wing Myles Stute was a top performer at this year&#x0027;s Metro Challenge 60. ","deleted":false,"author_name":"Scott Greene","author_title":"Publisher","permalink":"https://maryland.rivals.com/news/2020-four-star-wing-myles-stute-explodes-onto-scene-at-metro-challenge","site_name":"TerrapinSportsReport.com","type":"Content","programming":[],"associated_links":[]}], nil, 72, nil, true); subdomain = &#x0027;maryland&#x0027;; aolPlayerId = &#x0027;5964fbbe9efa8914c36f5f57&#x0027;; aolCompanyId = &#x0027;595eafc02a30cb7ee3e5396a&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #cc0000'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations' background-color='#cc0000' base-api-url='https://maryland.forums.rivals.com/' homepage='false' message-board-url='https://maryland.forums.rivals.com/forums/terps-insider-premium-forum.16/' pub-ad='null' size='size' space-id='2022733111' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations/printable' site-name='TerrapinSportsReport.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-13 09:41:24 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1913643/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Spring Practice No. 14: News, notes and observations</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/tydks03k15540otbh7uy)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/tydks03k15540otbh7uy" alt="Tydks03k15540otbh7uy" />
</div>
<figcaption class='image-caption'>The Terps held their 14th spring practice April 12. </figcaption>
<div class='image-credit'>Maryland Athletics</div>
</figure>
</div>
<div class='author-byline'>
<div class='title-sm' id='onetime-author'>Pat Donohue</div>
<div class='type-sm'>Staff Writer</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='preview-container'>
<div class='article-preview'><div class='st__content-block st__content-block--text article-text'>
<p><b>COLLEGE PARK, Md. --</b> Maryland football held its 14th spring practice April 12 on one of the few warm and sunny days we’ve had this year. It marked the final spring practice that is open to media, as head coach DJ Durkin and his team prepare for Saturday’s spring game. Durkin addressed reporters prior to the start of practice, and a handful of players spoke with media at the conclusion. Below are some news, notes and observations from spring practice No. 14.</p>
</div>
</div>
<div class='fade-container'>
<div class='article-fade'></div>
<h3 class='article-heading'>Backfield versatility bodes well for Terps new offense</h3>

</div>
</div>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=72">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations/printable' site-name='TerrapinSportsReport.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":72,"legacy_id":906,"name":"TerrapinSportsReport.com","friendly_name":"Maryland","annual_discount":null,"subdomain":"maryland","primary_color":"cc0000","secondary_color":"ffcd23","font_color":"ffffff","short_name":"maryland","maple_ncaaf_team_id":5,"maple_ncaaf_endpoint":"ncaaf/teams/mmd","maple_ncaab_team_id":343,"maple_ncaab_endpoint":"ncaab/teams/maj","maple_college_id":5,"google_analytics_id":"UA-83218492-1"}' twitter-feed='{"id":72,"site_id":72,"handle":"TerrapinNation","list_name":"terrapin-sports-report","created_at":"2016-02-01T12:25:04.466-06:00","updated_at":"2018-01-30T17:59:21.948-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations/printable' site-name='TerrapinSportsReport.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733111', 'https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Spring Practice No. 14: News, notes and observations";
  _sf_async_config.sections = 'content,content-football,content-football-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://maryland.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733111",
    c7: "https://maryland.rivals.com/news/spring-practice-no-14-news-notes-and-observations"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fmaryland.rivals.com%2Fnews%2Fspring-practice-no-14-news-notes-and-observations&c5=2022733111&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
